SITIO DEDICADO  SOLO A EXCEL 2007 Y EXCEL 2003, CON TUTORIALES Y EJERCICIOS  RESUELTOS DE  TODOS LOS TEMAS

NIVELES, BASICO, MEDIO Y AVANZADO

FORMULAS MATRICIALES

 

INTRODUCCION:

Con las fórmulas matriciales se pueden hacer muchas cosas, es una herramienta de gran potencia,  en general estas fórmulas o funciones se usan para hacer 2 tipos de cosas.:


  • Ejecutar varias operaciónes y devolver un único valor en la celda donde se la introduce.
  • Ejecutar varias operaciónes y devolver múltiples valores en distintas celdas.

Las fórmulas matriciales actúan en 2 o mas rangos de valores, los que se denominan, argumentos matriciales, los cuales tienen la característica de tener el mismo número de filas y de columnas, por ejemplo, podrían actuar sobre los rangos A1:A12  y BI:B12.
Una fórmula matricial se introduce de la misma forma que la fórmula común, la diferencia es que luego de introducirla hay que apretar las teclas Control+shift+ENTER, con lo que automáticamente es rodeada por llaves y es por eso que se las conoce como fórmulas CSE. Para una formula matricial multiplicar 2 argumentos matriciales, como A1:A12 *BI:B12. significa multiplicar las celdas A1*B1, A2*B2, A3*B3......A12*B12 si quiero sumar estos resultados parciales uso la formula matricial {SUMA(A1:A12*B1:B12)}, para aclarar los conceptos vamos a tener que hacer mas de un ejemplo, Empecemos por un ejemplo del tipo 1-.


        El dueño de una mueblería quiere aumentar la variedad de los productos que vende para lo que decide comprar, parte de los tradicionales, muebles de computación, para lo que cuenta con la siguiente planilla

 

y quiere saber  cuanto tiene que gastar. Decide tomar el camino corto y usa una simple fórmula matricial, veamos lo que hizo

se ve que introdujo la fórmula matricial

de esta forma hizo 3 pasos en uno. Los 3 pasos hubieran sido:

          1- Introducir la fórmula =D2*E2 en la celda F2.

          2- Arrastrar esta fórmula hasta la celda F7

          3- Ubicarnos en la celda F8 y pulsar el icono

o ubicarnos en la celda D9( por ejemplo ) e introducir la función

=SUMA(D2*E2;D3*E3;D4*E4;D5*E5;D6*E6;D7*E7)

se ve que ambas maneras, si bien dan el mismo resultado, son mucho mas tediosas

Se puede aprovechar este mismo ejemplo para mostrar como usar las fórmulas matriciales que devuelven múltiples valores y así explicamos todo el proceso.Usando la misma tabla que al principio vamos a obtener todos los productos parciales

          1º  seleccionamos la columna donde queremos que aparezcan los valores

.

  

2º En la barra de fórmulas, introducimos la fórmula obtenida mediante la selección de los rangos D2:D7 y E2:E7 multiplicados entre si

        3º apretamos las teclas Control+shift+ENTER

y obteniendo los productos parciales y por lo tanto múltiples resultados como se ve en el recuadro rojo.

Vamos a dar otro ejemplo para aclarar mas las cosas..

 

 

TUTORIALES

 

 

 

Copyright © 2009. Diseño José María César Leston
Free Web Hosting

http://www.000webhost.com/