SITIO DEDICADO  SOLO A EXCEL 2007 Y EXCEL 2003, CON TUTORIALES Y EJERCICIOS  RESUELTOS DE  TODOS LOS TEMAS

NIVELES, BASICO, MEDIO Y AVANZADO

FUNCION SI() ANIDADA CON LA FUNCIION Y() O()

 

La función SI es una de las que mas se usan para el anidamiento ya que su estructura es muy adecuada para esto:

 

  • En el parámetro 1 hay que poner una fórmula lógica, un anidamiento con funciones lógicas o la propia función si actuando como función lógica.
  • En loa parámetros 2 y 3 se pueden anidar una multitud de funciones, como funciones lógicas, lafunciñon si() actuando como función condicional o lógica etc.

Ahora vamos a ver un un ejemplo relativamente simple de la situación del punto 1.

Una empresa quiere promover a una nueva sección a los empleado que cumplan con las siguientes condiciones : 

 

  • Pertenecer al turno mañana.
  • Ser de la categoría 1 o que su sueldo sea menor o igual a 7.000$.

Para esto cuenta con la siguiente tabla que debe ser completada; donde los turnos son M,T ,N ,correspondientes a mañana, tarde y noche respectivamente y las secciones van de 1 a 4

Que se resuelve utilizando la fórmula

=SI(Y(O(E2=4;D2<=7000);Y(C2="M"));"PROMUEVE";"NO PROMUEVE")

como se ve, en el 1º parámetro tenemos una función Y que tiene anidadas en sus parámetros, una función O y otra función Y,  lo que aumenta el número de posibilidades que se están evaluando o condiciones que se tienen que cumplir como:

ser del turno mañana (se tiene que cumplir siempre).

ser de  la categoría 1 o que su sueldo sea <=7.000$ o ambas cosas.

Este es un ejemplo relativamente simple, anidando en el parámetro 1 y sin anidar nada en los otros dos, pero la complejidad puede aumentar grandemente.

 

Copyright © 2009. Diseño José María César Leston
Free Web Hosting

tp://www.000webhost.com/